How To: Extend the Ed-Fi ODS / API - Student Transcript

Example

In this example, we will create a new domain entity called Student Transcript. This entity will be exposed
in Ed-Fi ODS / API through a new API resource called studentTranscripts.

Before you begin:

® This example uses MetaEd to generate extended artifacts and documentation. MetaEd is a free
tool developed by the Ed-Fi Alliance, and is the recommended way to add new fields to the Ed-
Fi ODS / API. You should download and install MetaEd before beginning. If you prefer to
generate extended artifacts manually instead of using MetaEd, steps are listed in Appendix A of
this page.

® This example assumes knowledge of the basic concepts described in the How To: Extend the
ODS / API - Student Transportation Example. If you're new to the Ed-Fi technology stack, or if
you haven't used MetaEd before, then we suggest you run through that example first.

® This example assumes that the Ed-Fi ODS / API has been successfully downloaded and is
running in a local development environment per the instructions in the Getting Started document
ation.

® Back up any existing code or scripts, either in source control or on your file system. This is
important if you or your team have performed these steps before. The MetaEd deployment
feature replaces existing files, some of which may contain hand-crafted customizations (e.g., to
define an authorization strategy).

The steps can be summarized as:

Step 1. Design Your Extension

Step 2. Author Your Extension Using MetaEd

Step 3. Generate Extended Technical Artifacts Using MetaEd
Step 4. Create Extension Project in ODS / API Solution

Step 5. Deploy your Extended Artifacts to the ODS / API Solution
Step 6. Configure Security

Step 7. Run Code Generation and Verify Changes

Each step is outlined in detail, below.

Step 1. Design Your Extension

In a real project, you would take the preliminary step of designing your extension, and analyzing how
your needs map to the Ed-Fi ODS / API data model. We'll propose a design.

This example will create a new Student Transcript entity, which will carry information about where
students enroll in college after graduation, a new element indicating whether graduates were part of a
special education program, and some additional information about whether a transmitted record is an
official or unofficial submission.

Based on our needs, we require a new entity (to contain information about postsecondary institutions)

and we need to add some elements to existing entities. The following is a diagram is a sketch showing
the additional entity and the new elements we're bolting on to existing Ed-Fi entities.

PostSecondaryOrganization
Has Associated (New Entity)

StudentAcademicRecord
(Extended Ed-Fi Entity)

ClassRanking
(Extended Ed-Fi Entity)

Has Associated

You'll notice that a few elements are shown with a type of "descriptor."” The Ed-Fi Descriptor is analogous
to an enumeration. It's an Ed-Fi-specific design pattern that allows for enumeration-like definition and
validation within an operational context, but may vary between contexts. We'll see more about how these
are implemented below.

This example is somewhat complex, but illustrates most of the advanced concepts required to extend the
Ed-Fi ODS / API. Let's continue with the mechanics.

Downloads

The following GitHub links contain
source files for this extensibility
sample.

® Student Transcript MetaEd
Source

® Student Transcript
Generated Artifacts


https://techdocs.ed-fi.org/display/METAED20/Getting+Started+with+the+MetaEd+IDE
https://techdocs.ed-fi.org/pages/viewpage.action?pageId=149587472
https://techdocs.ed-fi.org/pages/viewpage.action?pageId=149587472
https://techdocs.ed-fi.org/display/ODSAPIS3V61/Getting+Started+-+Source+Code+Installation
https://github.com/Ed-Fi-Alliance-OSS/Ed-Fi-ODS/tree/v6.1/Samples/Extensions/StudentTranscript/StudentTranscriptMetaEd
https://github.com/Ed-Fi-Alliance-OSS/Ed-Fi-ODS/tree/v6.1/Samples/Extensions/StudentTranscript/StudentTranscriptMetaEd
https://github.com/Ed-Fi-Alliance-OSS/Ed-Fi-ODS/tree/v6.1/Samples/Extensions/StudentTranscript/StudentTranscriptMetaEd/MetaEdOutput/SampleStudentTranscript
https://github.com/Ed-Fi-Alliance-OSS/Ed-Fi-ODS/tree/v6.1/Samples/Extensions/StudentTranscript/StudentTranscriptMetaEd/MetaEdOutput/SampleStudentTranscript

Step 2. Author Your Extension Using MetaEd

In this step, we'll create a new project in MetaEd, and author our new entity. You do need to download
and install MetaEd to do this step. Do that now if you haven't already.

Step 2a. Set or Confirm MetaEd Target Version

MetaEd allows you to target different versions of the Ed-Fi technology stack and data model. Confirm
that your MetaEd IDE is targeting v6.1 by following the instructions in the Version Targeting documentatio

n for the MetaEd IDE.

The desired model for the latest ODS / APl is "ed-fi-model-4.0a".

Step 2b. Create a New Extension Project

Create a new extension by following the steps in MetaEd IDE - Creating and Maintaining Your Extension.
In this example our extension is in a folder called "StudentTranscript"

Step 2c. Update the package.json File

Open the package.json file by double-clicking on the file in the tree view to the left and provide an
appropriate name for your project. In this case we will call it "SampleStudentTranscript".

Click "Save" under the "File" menu or press Ctrl + S to save your changes.

Step 2d. Add MetaEd Source Files to Your Project

We're going to add seven new .metaed source files to the project we just created. You'll recall that
MetaEd files are required to be organized into subfolders named after their entity type. The core ed-fi-
model project provides examples of subfolder naming.

2d.1. Add Domain Entities.

Now we'll add two MetaEd source files to the DomainEntity folder. Right-click on the folder DomainEntity
, and select New File.
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Name the new file PostSecondaryOrganization.metaed to match the name of the new entity to be
created.

Note the new file appears in the tree view to the left. Double-click on the file in the tree view to open it. T
ype or copy and paste the code listing below into your MetaEd file:

Note that errors will be listed in the linter panel until the referenced Descriptors are created in a future
step.

MetaEd Source for PostSecondaryOrganization Entity

Domai n Entity Post SecondaryOrgani zati on
docunent ati on " Post Secondar yOr gani zati on"
shared string EdFi . NameCOf I nstitution
docunentation "The nane of the institution.”
is part of identity
descriptor InstitutionLevel
docunentation "The | evel of the institution.”
is required
descriptor InstitutionControl
docurmentation "The type of control of the institution (i.e.
public or private)."
is required
bool Acceptancel ndi cat or
docunentation "An indication of acceptance."
is required



We'll now create a Domain Entity source file, called StudentAcademicRecordExtension, to add our
new elements to the existing Student Academic Record entity. Note that we can extend an existing entity
using the addi t i ons keyword (line 1 in the example below).

MetaEd Source for StudentAcademicRecordExtensions Entity

Domei n Entity EdFi.Student Acadenm cRecord additions

donmain entity Post SecondaryQOrgani zati on
docunmentation "A reference to the postsecondary organi zation."
is optional

descriptor Submi ssionCertification
docunentation "The type of subm ssion certification."
is optional

common ext ensi on EdFi . O assRanki ng
docunentation "Cl ass Ranki ng Extension"
is optional

2d.2. In this step, we'll extend the Class Ranking entity to add our new Special Education Graduation
Status element. The steps are generally the same as the ones you used to add the domain entities
above.

Right-Click on the Common folder, select New File. Name your new file ClassRankingExtension.
metaed.

Similar to how you extended the Student Academic Record domain entity above, you'll extend the Class
Ranking entity with the keyword addi t i ons. Replace the template text in your new Common source file
with the following code.

MetaEd Source for ClassRankingExtensions Common Type

Common EdFi . C assRanki ng addi tions
descri ptor Speci al Educati onG aduati onSt at us
docunentati on "The graduation status for special education.”
is required

2d.3. In this step, we'll add the new Ed-Fi Descriptor entities.



If you're new to Ed-Fi technology, it's worth understanding the Ed-Fi Descriptor pattern because it occurs
throughout the model. In essence, Descriptors provide states, districts, vendors, and other platform hosts
with the flexibility to use their own enumerations and code sets. A Descriptor is consistent within an
operational context such as a single district, but may be different in another operational context.

Right-click on the Descriptor folder, select New File. We'll be adding four Descriptor files in total. Name
your first file InstitutionControl.metaed.

Replace the template text in your new Descriptor source file with the following code.

MetaEd Source for InstitutionControl Descriptor

Descriptor InstitutionControl
docunentation "The type of control for an institution (e.g., public or
private)."

Voila! Almost done. Follow the steps above and add the remaining three Descriptors.

Add an InstitutionLevel.metaed file.

MetaEd Source for InstitutionLevel Descriptor

Descriptor InstitutionLevel
docunentation "The typical |evel of postsecondary degree offered by
the institute."

Add a SpecialEducationGraduationStatus.metaed file.



MetaEd Source for SpecialEducationGraduationStatus Descriptor

Descri ptor Speci al Educati onG aduati onSt at us
docunentation "The graduation status for special education.”

Add a SubmissionCertification.metaed file.

MetaEd Source for SubmissionCertification Descriptor

Descriptor Submi ssionCertification
docunentation "The type of subm ssion certification.”

2d.4. In this step, we'll add the new Interchange file.
If you want to bulk load this extension, you need to create an interchange file.

Right-click on the Interchange folder, select New File. Name your file StudentTranscript.metaed.
Replace the template text in your new Interchange source file with the following code.

MetaEd Source for StudentTranscript Interchange

I nterchange EdFi. Student Transcri pt additions
domain entity Post SecondaryOrgani zation




At this point, your project in the MetaEd IDE should look like the following:

Step 3. Generate Extended Technical Artifacts
Using MetaEd

In this step, we'll build our new MetaEd project. This is fairly straightforward.

Step 3a. Build Your Project

Click Build in the VS Code menu to generate artifacts.

Artifacts build successfully.

Step 3b. View MetaEd Output

You can expand the project in the tree view and click "MetaEdOutput" to explore generated artifacts. The
artifacts include technical output such as SQL scripts and XSD used by the code generation, but also
updated documentation such as data dictionaries that add your extension definitions to the ODS / API
documentation.

We'll look at how to use this MetaEd output in your code below. First, we'll need to set up our extension
project in Visual Studio.



Step 4. Create Extension Project in ODS / API
Solution

This step will create the C# Extension files necessary to build your extended solution. This step assumes
you've successfully downloaded and can run the ODS / API in a local development environment per the
instructions in the Getting Started documentation. Do that now if you haven't already.

Step 4a. Set Up the C# Project Template

Visual Studio Project Templates can be installed by following steps in Project Templates Installation secti
on of this documentation.

Step 4b. Create new Extension Project

4b.1. To add a project to your Ed-Fi-Ods Visual Studio Solution, right-click on the Ed-Fi Extensions
Folder. Select Add > New Project.

Add a new project

Recent project templates

In the Project Name field, enter EdFi.Ods.Extensions.SampleStudentTranscript and click Create.

Configure your new project

Ed-Fi AP Extensions Project Template

@ Note

To ensure MetaEd outputs are correctly deployed to ODS / API extension project, the last
section of the project name should match the namespace you provided in Step 2.c with the
first character in upper case.


https://techdocs.ed-fi.org/display/ODSAPIS3V61/Getting+Started
https://techdocs.ed-fi.org/display/ODSAPIS3V61/Project+Templates+Installation

Step 4c. Rename the "Marker" Interface file

4c.1. Right-click on the Marker_EdFi_Ods_Extensions_ExtensionName.cs file in newly created EdFi.
Ods.Extensions.SampleStudentTranscript project and Rename the file to Marker_EdFi_Ods_Extensi
ons_SampleStudentTranscript.cs.

SampleStudentTranscript
Dependencies
semblyMetadata.j
P+ c# Marker EdFi Ods Extensions_ExtensionMame.cs

Open

Open With...

Run Tests

Debug Tests

Code Cleanup

Scope to This

olution Explorer View

Exclude From Project
Ctrl+X
Ctrl+C

Delete

Rename

Full Path

Refactor
Edit project item properties
Go to File Nearby

lapse All

Properties Alt+Enter

4c.2. When prompted choose to rename all references to the code element Marker_EdFi_Ods_Extensio
ns_ExtensionName.

Microsoft Visual Studio

You are renaming a file. Would you also like to perform a rename in
this project of all references to the code element
‘Marker_EdFi_Ods_Extensions_ExtensionName'?

Yes No

Step 4d. Integrate Extension into the Solution
In this step, we'll integrate the extension into the solution.

4d.1. Locate the EdFi.Ods.WebApi project, within the "Entry Points" folder. Right-click, select Add > Pr
oject Reference..., then select the EdFi.Ods.Extensions.SampleStudentTranscript project.

Reference Manager - dF.0ds WebApi

pleStudentTrans




4d.2. Locate any profile projects in the solution. Right-click, select Add > Project Reference..., then
select the EdFi.Ods.Extensions.SampleStudentTranscript project. This step is needed only if any of
the Profile resources in the Profiles.xml document are extended, or extension entities are being
constrained by a particular Profile.

Step 5. Deploy your Extended Artifacts to the ODS /
API Solution

In this step, we'll use the MetaEd "Deploy” feature and integrate the files you've generated with the ODS
/ API Solution. The MetaEd IDE can deploy the generated artifacts necessary for an ODS / API build of
an extension project. These include the generated SQL, generated XSD, and other material.

You can easily configure the MetaEd IDE to copy the generated files to the correct locations for the ODS
| API project.

Step 5a. Confirm MetaEd Deployment Settings

Ensure that your Ed-Fi ODS / API source directory is set properly in the MetaEd Extension settings. In
VS Code open Settings Ctrl+, and switch to the Workspace tab, find the MetaEd extension and update
the "Ods Api Deployment Directory” to point to the folder that contains the Ed-Fi-ODS and Ed-Fi-ODS-
Implementation folders.

Step 5b. Deploy Your Extended Artifacts

1 Asnoted above, deployment will remove existing SQL scripts — including modifications to
establish the authorization strategy as described in the next step. Verify that you have a
source control copy or file backup of previous work before running deployment.

Deploy by clicking Deploy on the VSCode menu

This will run a new build of all artifacts, and the artifacts required for your Extended ODS / API project will
be copied over to the correct locations.

For instructions on how to perform the steps manually, see Appendix A, below.

Step 6. Configure Security



The Ed-Fi ODS / APl is secure by default. One implication of this design principle is that new entities and
elements may not be accessed until an authorization strategy is applied. This prevents accidental release
of confidential information, but does require active steps on the part of system developers to enable
access to Extensions.

PostSecondaryOrganization has no relationship to people or education organizations and therefore has
no authorization strategy that can be applied to it. In effect, it is a standalone table and will need an
authorization strategy of "NoFurtherAuthorizationRequired" for API requests to be made against it. If
security is desired, another authorization strategy could be implemented to handle this entity.

To enable NoFurtherAuthorizationRequired, first create a security SQL script called 0001-
PostSecondaryOrganization_No_Further_Auth_Required.sql and place it in the Ed-Fi-ODS-
Implementation\Application\EdFi.Ods.Extensions.
SampleStudentTranscript\Artifacts\MsSql\Data\Security folder (Create 'Security’ folder if it does not
exist). Copy the contents of the following SQL DML script into the newly created file and save.

0001-PostSecondaryOrganization_No_Further_Auth_Required.sql

-- SPDX-License-ldentifier: Apache-2.0

-- Licensed to the Ed-Fi Alliance under one or nore agreenents.

-- The Ed-Fi Alliance licenses this file to you under the Apache License,
Version 2.0.

-- See the LICENSE and NOTICES files in the project root for nore

i nfornation.

DECLARE @\pplicationld I NT
DECLARE @pystenDescriptorslid | NT

SELECT @\pplicationld = Applicationld
FROM [ dbo] . [ Appl i cati ons]
WHERE ApplicationName = 'Ed-Fi ODS API'

SELECT @pystenDescriptorsld = resourceclaimd
FROM  [dbo].[resourcecl ai ns]
WHERE di spl aynane = 'systenDescriptors'

I NSERT | NTO [ dbo] . [ resourcecl ai ns]
([ di spl aynane],

[ resour cenane],

[ cl ai mane],

[ parentresourcecl ai md],

[application_applicationid])
VALUES ( 'institutionControl Descriptor',

"institutionControl Descriptor',

"http://ed-fi.org/ods/identity/clains/sanple-student-transcript
/institutionControl Descriptor',
@yst emDescri ptorsld,
@\pplicationld )

I NSERT | NTO [dbo] . [resourcecl ai ns]
([ di spl aynane],
[ resourcenane],
[ cl ai mane],
[ parentresourcecl ai md],
[application_applicationid])
VALUES ( "institutionLevel Descriptor',
"institutionLevel Descriptor',
"http://ed-fi.org/ods/identity/clains/sanple-student-
transcript/institutionLevel Descriptor’',
@yst enDescri ptorsld,
@\pplicationld )

I NSERT | NTO [dbo] . [resourcecl ai ns]
([ di spl aynane] ,

[ resourcenane],

[ cl ai mane],

[ parentresourcecl ai md],

[application_applicationid])
VALUES ( ' speci al Educati onGraduati onSt at usDescri ptor',

' speci al Educati onG aduati onSt at usDescri ptor',

"http://ed-fi.org/ods/identity/clains/sanple-student-transcri pt



/ speci al Educat i onGraduat i onSt at usDescri ptor'

@yst emDescri ptorsld,
@\pplicationld )

I NSERT | NTO [ dbo] . [ resourcecl ai ns]
([ di spl aynane],

[ resour cenane],

[ cl ai mane],

[ parentresourcecl ai md],

[application_applicationid])
VALUES ( 'submi ssionCertificationDescriptor',

' submi ssionCertificationDescriptor',

"http://ed-fi.org/ods/identity/clains/sanple-student-transcript
/ submi ssionCertificationDescriptor',
@yst emDescri ptorsld,
@\pplicationld )

I NSERT | NTO [ dbo] . [ ResourceC ai ms] (
[ Di spl ayNane]
, [ Resour ceNane]
, [ 4 ai mNane]
, [ Par ent Resour ceC ai ni d]
, [ Application_Applicationld]
)
VALUES (
' post Secondar yOr gani zat i on'
, ' post Secondar yOr gani zati on'
,"http://ed-fi.org/ods/identity/clains/sanple-student-transcri pt
/ post Secondar yOr gani zat i on'
, NULL
, @\pplicationld
)

--Setup Authorization Strategy

DECLARE @Aut hori zationStrategyld I NT
DECLARE @RresourceClaimd | NT

SELECT @A\ut horizationStrategyld = AuthorizationStrategyld
FROM Aut hori zati onStr at egi es
WHERE Aut hori zationStrat egyNanme = ' NoFurt her Aut hori zati onRequi r ed'

SELECT @ResourceC aim d = resourceclaimd
FROM Resour ced ai ns
WHERE Resour ceNanme = 'post SecondaryOrgani zati on'

I NSERT | NTO [ dbo] . [ Resour ceCl ai mActi ons] (
[ Resour ced ai m d]
,[Actionld]
, [ Val i dat i onRul eSet Nane]
)
SELECT ResourceC aimd, a.Actionld, null
FROM [ dbo] . [ Resour ced ai ns]
CRCSS APPLY (
SELECT Actionld
FROM [ dbo] . [ Acti ons]
WHERE ActionNane IN ('Create', 'Read', 'Update', 'Delete',
' ReadChanges')) AS a
WHERE ResourceC aimd = @Resourced aimd

I NSERT | NTO [ dbo] . [ Resour ceCl ai mAct i onAut hori zationStrat egi es] (
[ Resour ced ai mAct i onl d]
,[Aut hori zati onStrat egyl d]
)
SELECT Resourced ai mActionld, @\uthorizationStrategyld
FROM [ dbo] . [ Resour ced ai mActions] rca
I NNER JO N [dbo] . [ Resourced ai nms] rc
ON rca. [ ResourceC aimd] = rc.[Resourced ai nd]
INNER JO N [dbo] . [Actions] a
ON rca. Actionld = a.Actionid



AND a. ActionNarme IN (' Create',' Read','Update',' Delete',
' ReadChanges' )
WHERE rc. ResourceCl aimd = @Resourced aimd

--Add to SIS Vendor and Ed-Fi Sandbox clai msets
I NSERT | NTO [ dbo] . [ O ai nSet Resour ceC ai mAct i ons]
SELECT [ ai nBSet | d]
, [ Resour ced ai nml d]
, [Acti onl d]
, NULL
FROM Actions a
,ClainBets ¢
, ResourceC ains r
WHERE r. Resour ceNanme = ' post Secondar yOr gani zati on'
AND (
c.d ai nSet Name = ' SI'S Vendor'
OR c. d ai nSet Nane = ' Ed-Fi Sandbox'
)
AND NOT EXI STS (
SELECT 1
FROM Cl ai nSet Resour ced ai mActi ons csrca
WHERE csrca. Actionld = a. Actionld
AND csrca.d ainSetld = c.d ai nSet | d
AND csrca. ResourceClaimd = r.Resourced ai md

Preventing Resource Name Conflicts

With MetaEd 2+, it is possible to create extension resources that use the same name as an Ed-Fi
standard resource. The authorization metadata supports this through a change in behavior so it no longer
uses just the resource name to identify the resource, but instead uses the ClaimName. To prevent
possible naming conflicts, the claim name's URI value should include the schema representation, using
the following format:

http://ed-fi.org/ods/identity/claims/{schema}/{resourceName}

The URI representation of the schema name should be derived by splitting the terms in the name of the
extension, inserting hyphens and converting to lower case. For example, "SampleStudentTranscript"
would be separated into "Sample", "Student" and "Transcript" and then combined with hyphens and
converted to lower case as "sample-student-transcript".

The resource name should be the camel-cased (also known as "medial capitals"), singularized name of
the resource (e.g., "postSecondaryOrganization" not "PostSecondaryOrganization" or
"postSecondaryOrganizations").

Note that in 0001-PostSecondaryOrganization_No_Further_Auth_Required.sql script above, the resulting
ClaimName value is "http://ed-fi.org/ods/identity/claims/sample-student-transcript
IpostSecondaryOrganization”.

Step 7. Run Code Generation and Verify Changes

Save all modified files, close Ed-Fi-ODS.slIn, and re-run the code generation steps outlined in the Getting
Started Guide (i.e., from a PowerShell prompt run I ni ti al i ze- Power shel | For Devel opnent . ps scr
ipt, followed by the i ni t dev command). Then, run the application and view the Ed-Fi ODS / API in the
Swagger Ul.

The new postSecondaryOrganizations API resource should be visible, as well as the postSecondaryOrg
anizationReference in the studentAcademicRecord resource.

postSecondaryOrganizations osisecondanoraniaion o



http://ed-fi.org/ods/identity/claims/{schema}/{resourceName
http://ed-fi.org/ods/identity/claims/sample-student-transcript/postSecondaryOrganization
http://ed-fi.org/ods/identity/claims/sample-student-transcript/postSecondaryOrganization
https://techdocs.ed-fi.org/display/ODSAPIS3V61/Getting+Started+-+Source+Code+Installation
https://techdocs.ed-fi.org/display/ODSAPIS3V61/Getting+Started+-+Source+Code+Installation

Next Steps & Further Information

Congratulations, you've successfully extended an instance of the Ed-Fi ODS / API.
The Ed-Fi Extension in this example is fairly simple. It's a good place to start, but most enterprise users

have more complicated needs. The MetaEd Cookbook documentation provides excellent additional
examples of common scenarios, from the simple to very complex.

Appendix A: Adding Manually Created Extensions

Step 1. Set Up the C# Project Template

Visual Studio Project Templates can be installed by following steps in Project Templates Installation secti
on of this documentation.

Step 2. Create new Extension Project

2.1. To add a project to your Ed-Fi-Ods Visual Studio Solution, right-click on the Ed-Fi Extensions
Folder. Select Add > New Project.

Solution Explorer

2.2. Search and select the Ed-Fi API Extensions Project Template option and click Next.


https://techdocs.ed-fi.org/display/METAED20/Cookbook+-+Introduction
https://techdocs.ed-fi.org/display/ODSAPIS3V61/Project+Templates+Installation

Add a new project

Recent project templates

In the Project Name field, enter EdFi.Ods.Extensions.SampleStudentTranscript and click Create.

Configure your new project

Ed-Fi API Extensions Project Template

Step 3. Rename the "Marker" Interface File

3.1. Right-click on the Marker_EdFi_Ods_Extensions_ExtensionName.cs file in newly created EdFi.
Ods.Extensions.SampleStudentTranscript project and Rename the file to Marker_EdFi_Ods_Extensi
ons_SampleStudentTranscript.cs.

ampleStudentTranscript

+ 5T mblyMetadata
+c# Marker EdFi Ods Extensions_ExtensionMame.cs

Open

Ctrl+X

Ctrl+C :
lopment.json

S

spec
Rename

y Full Path
Open taining

Find Code |s:

Edit project item properties
o to File Nearby
lapse All

Properties Alt+Enter




3.2. When prompted choose to rename all references to the code element Marker_EdFi_Ods_Extensio
ns_ExtensionName.

Microsoft Visual Studio

You are renaming a file. Would you also like to perform a rename in
this project of all references to the code element
‘Marker_EdFi_Ods_Extensions_ExtensionMName'?

Yes No

Step 4. Integrate Extension into the Solution
In this step, we'll integrate the extension into the solution.

4.1. Locate the EdFi.Ods.WebApi project, within the "Entry Points" folder. Right-click, select Add > Ref
erence..., then select the EdFi.Ods.Extensions.SampleStudentTranscript project.

[<J<<]
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4.2. Locate any profile projects in the solution. Right-click, select Add > Project Reference..., then
select the EdFi.Ods.Extensions.SampleStudentTranscript project. This step is needed only if any of
the Profile resources in the Profiles.xml document are extended, or extension entities are being
constrained by a particular Profile.

Step 5. Add Extension Metadata

If you chose to generate Extension artifacts manually, copy them to Artifacts folder of Extension project
you created in the previous step. For the purpose of this example we can use MetaEd Generated
Extension Artifacts from the Download section.

Open command prompt and navigate to root of the ODS / API repository on your local drive. This is the
folder that contains both Ed-Fi-ODS and Ed-Fi-ODS-Implementation repositories. Run the following copy
commands:

xcopy /y "Ed-Fi-

ODS\ Sanpl es\ Ext ensi ons\ St udent Transcri pt\ St udent Tr anscri pt Met aEd\ Met aEdCut p
ut\ Sanpl eSt udent Transcri pt\ Dat abase\ SQLSer ver\ ODS\ St ruct ure" "Ed- Fi - ODS-

I npl ement ati on\ Appl i cati on\ EdFi . Ods. Ext ensi ons.

Sanpl eSt udent Transcri pt\Artifacts\MsSgl\Structure\ Gds\ *"

xcopy /y "Ed-Fi-

ODS\ Sanpl es\ Ext ensi ons\ St udent Transcri pt\ St udent Tr anscri pt Met aEd\ Met aEdQut p
ut\ Sanpl eSt udent Transcri pt\ Dat abase\ Post gr eSQL\ ODS\ St ruct ure" "Ed- Fi - ODS-

I npl ement ati on\ Appl i cati on\ EdFi . Ods. Ext ensi ons.

Sanpl eSt udent Transcri pt\ Artifacts\PgSqgl\ Structure\ Qds\ *"

xcopy /y "Ed-Fi-

ODS\ Sanpl es\ Ext ensi ons\ St udent Transcri pt\ St udent Tr anscri pt Met aEd\ Met aEdQut p
ut \ Sanpl eSt udent Transcri pt\ Api Met adat a" " Ed- Fi - ODS-

I npl enent ati on\ Appl i cati on\ EdFi . Ods. Ext ensi ons.

Sanpl eSt udent Transcri pt\Artifacts\ Metadata\*"

xcopy /y "Ed-Fi-

ODS\ Sanpl es\ Ext ensi ons\ St udent Transcri pt\ St udent Transcri pt Met aEd\ Met aEdQut p
ut\ Sanpl eSt udent Transcri pt\ XSD' "Ed- Fi - ODS- | npl enent at i on\ Appl i cati on\ EdFi .
Qds. Ext ensi ons. Sanpl eSt udent Transcri pt\ Artifact s\ Schemas\ *"



xcopy /y "Ed-Fi-

ODS\ Sanpl es\ Ext ensi ons\ St udent Transcri pt\ St udent Transcri pt Met aEd\ Met aEdQut p
ut\ Sanpl eSt udent Transcri pt\ | nt erchange" "Ed- Fi - ODS-

I npl ement ati on\ Appl i cati on\ EdFi . Ods. Ext ensi ons.

Sanpl eSt udent Transcri pt\ Artifact s\ Schemas\ *"

Step 6. Configure Security

The Ed-Fi ODS / API is secure by default. One implication of this design principle is that new entities and
elements may not be accessed until an authorization strategy is applied. This prevents accidental release
of confidential information, but does require active steps on the part of system developers to enable
access to Extensions.

PostSecondaryOrganization has no relationship to people or education organizations and therefore has
no authorization strategy that can be applied to it. It is in effect a standalone table and will need an
authorization strategy of "NoFurtherAuthorizationRequired" for API requests to be made against it. If
security is desired, another authorization strategy could be implemented to handle this entity.

To enable NoFurtherAuthorizationRequired, first create a security SQL script called 0001-
PostSecondaryOrganization_No_Further_Auth_Required.sql and place it in the C:\Ed-Fi-ODS-
Implementation\Artifacts\MsSql\Data\Security folder (Create 'Security' folder if it does not exist). Copy the
contents of the following SQL DML script into the newly created file and save.

0001-PostSecondaryOrganization_No_Further_Auth_Required.sql

-- SPDX-License-ldentifier: Apache-2.0

-- Licensed to the Ed-Fi Alliance under one or nore agreenents.

-- The Ed-Fi Alliance licenses this file to you under the Apache License,
Version 2.0.

-- See the LICENSE and NOTICES files in the project root for nore

i nfornation.

DECLARE @\pplicationld INT
DECLARE @pystenDescriptorslid | NT

SELECT @Mpplicationld = Applicationld
FROM [ dbo] . [ Appl i cati ons]
WHERE ApplicationName = 'Ed-Fi ODS API'

SELECT @pystenDescriptorsld = resourceclaimd
FROM [ dbo].[resourcecl ai ns]
WHERE di spl aynane = 'systenDescriptors'

I NSERT | NTO [ dbo] . [resourcecl ai ns]
([ di spl aynane],

[ resour cenane] ,

[ cl ai mane],

[ parentresourcecl ai md],

[ application_applicationid])
VALUES ( 'institutionControl Descriptor',

"institutionControl Descriptor',

"http://ed-fi.org/ods/identity/clains/sanple-student-transcript
/institutionControl Descriptor',
@yst emDescri ptorsld,
@\pplicationld )

I NSERT | NTO [dbo] . [resourcecl ai ns]
([ di spl aynane],
[ resourcenane],
[ cl ai mane],
[ parentresourcecl ai md],
[application_applicationid])
VALUES ( "institutionLevel Descriptor',
"institutionLevel Descriptor',
"http://ed-fi.org/ods/identity/claimnms/sanple-student-
transcript/institutionLevel Descriptor',
@yst enDescri ptorsld,
@\pplicationld )



I NSERT | NTO [ dbo] . [resourcecl ai ns]
([ di spl aynane],

[ resourcenane],

[cl ai mane],

[ parentresourcecl ai md],

[application_applicationid])
VALUES ( 'special Educati onG aduati onSt at usDescri ptor',

' speci al Educati onG aduati onSt at usDescri ptor',

"http://ed-fi.org/ods/identity/clains/sanple-student-transcri pt
/ speci al Educat i onGr aduat i onSt at usDescri pt or'

@yst enDescri ptorsld,
@\wplicationld )

I NSERT | NTO [dbo] . [resourcecl ai ns]
([ di spl aynane] ,

[ resourcenane],

[ cl ai mane],

[ parentresourcecl ai m d],

[application_applicationid])
VALUES ( "submi ssionCertificationDescriptor',

' submi ssionCertificationDescriptor',

"http://ed-fi.org/ods/identity/clains/sanple-student-transcri pt
/ submi ssionCertificationDescriptor',
@yst enDescri ptorsld,
@\pplicationld )

I NSERT | NTO [ dbo] . [ ResourceC ai nms] (
[ D spl ayNamne]
, [ Resour ceNane]
, [ 4 ai mNane]
, [ Par ent Resour ced ai i d]
, [ Application_Applicationld]
)
VALUES (
' post Secondar yOr gani zat i on'
, ' post Secondar yOr gani zat i on'
,"http://ed-fi.org/ods/identity/clains/sanple-student-transcri pt
/ post Secondar yOr gani zat i on'
, NULL
, @\pplicationld
)

--Setup Authorization Strategy

DECLARE @Aut hori zationStrategyld I NT
DECLARE @ResourceC ainmid I NT

SELECT @A\ut horizationStrategyld = AuthorizationStrategyld
FROM Aut hori zati onStrat egi es
WHERE Aut hori zationStrategyNane = ' NoFurther Aut hori zat i onRequi r ed'

SELECT @ResourceCl aimd = resourceclaimd
FROM Resour ced ai ns
WHERE Resour ceNane = 'post Secondar yOrgani zati on'

I NSERT | NTO [ dbo] . [ Resour ceC ai mActi ons] (
[ ResourceC ai m d]
, [Acti onl d]
, [ Val i dati onRul eSet Nane]
)
SELECT ResourceC aimd, a.Actionld, null
FROM [ dbo] . [ Resour ced ai ns]
CROSS APPLY (
SELECT Actionld
FROM [ dbo] . [ Acti ons]
WHERE ActionName IN ('Create', 'Read', 'Update', 'Delete',
' ReadChanges')) AS a
WHERE ResourceC aimd = @esourceC ainmd



I NSERT | NTO [ dbo] . [ Resour ced ai mAct i onAut hori zati onStrategi es] (
[ Resour ced ai mAct i onl d]
,[Aut hori zati onStrat egyl d]
)
SELECT Resourced ai mActionld, @\wuthorizationStrategyld
FROM [ dbo] . [ Resour ceCl ai mActi ons] rca
INNER JO N [dbo] . [ ResourceC ains] rc
ON rca. [ ResourceC aimd] = rc.[Resourced ai nd]
INNER JO N [dbo] . [Actions] a
ON rca. Actionld = a.Actionid
AND a. ActionNane IN (' Create',' Read',' Update','Delete',
' ReadChanges' )
VWHERE rc. Resourced ainmld = @esourceC aind

--Add to SIS Vendor and Ed-Fi Sandbox clai msets
I NSERT | NTO [ dbo] . [ O ai nSet Resour ced ai mActi ons]
SELECT [ d ai nBet | d]
, [ Resour ced ai nm d]
, [Actionl d]
, NULL
FROM Actions a
,ClainBets c
, ResourceC ains r
WHERE r. Resour ceNanme = ' post Secondar yOrgani zati on'
AND (
c.d ai nSet Name = ' SI'S Vendor'
OR c. d ai nSet Nanme = ' Ed-Fi Sandbox'
)
AND NOT EXI STS (
SELECT 1
FROM Cl ai nSet Resour ced ai mActi ons csrca
WHERE csrca. Actionld = a. Actionld
AND csrca. ainSetld = c. d ai nSet | d
AND csrca. ResourceClaimd = r.Resourced ai md

Step 7. Run Initdev

Save all modified files, close Ed-Fi-ODS.sIn, and re-run the code generation steps outlined in the Getting
Started Guide (i.e., from a PowerShell prompt run I ni ti al i ze- Power shel | For Devel opnent . ps scr
ipt, followed by the i ni t dev command). Then, run the application and view the Ed-Fi ODS / API in the
Swagger Ul. The following new API resource should be visible:

postSecondaryOrganizations ossecondaryorgania o
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